• Confluence is currently running with all non-system plugins disabled, some functionality may be missing
Child pages
  • RE - Canvas
Skip to end of metadata
Go to start of metadata

The “Relationship Editor” window can be opened from the “Layout” menu or with the F5 key. Since it will be a central part of your work with RealFlow, we recommend adding the window to your GUI layout. Of course, RealFlow also supports dual-screen layouts and you can move the editor to a separate monitor as well. This is actually a very good idea, because with complex scenes, it is better to have more space where you can arrange and group your nodes.

The window’s main element is the canvas. By default this is just an empty area, but once you start to add objects, emitters or daemons, the canvas will be filled with nodes. When nodes are added, they are displayed as coloured circles and – if the appropriate feature is active – directly linked to a “Hub”. This behaviour can be changed under:

Edit > Add > Add to Default Hub

 

The colours indicate the node type:

Blue (pale)

Hybrido nodes including all emitters and mist

Blue (bright)

Particle emitters and RealWave surfaces

Red

Daemons

Yellow

Objects including imported nodes

Green

Meshes

Grey

Hubs, groups, IDOCS, and cameras including imported cameras

 

A node can be selected or deselected with a single click and when it is active you see a white circle around it. Multi-selections are possible with the Shift key or by dragging a rectangle around the icons. Cameras, for example, cannot interact with other elements of a scene and are therefore always stand-alone nodes. The lines between the circles are also coloured and they represent a certain hierarchy, e.g. when a link is created between an object and a daemon, the line will always be drawn in red. But, this is something you do not have to worry about, because all this is done automatically by RealFlow.

Navigation

Node-based systems with hundreds of connections can become confusing and difficult to handle. Therefore, it is of particular importance to keep a clear and integrated workflow.

The canvas provides a navigation window in the lower right corner, but it is only active if one or more nodes are not visible. Inside the window you can see a copy of the node layout (without connections) and a light-grey rectangle – the currently visible section of the canvas. You can drag the box to reach other parts of the canvas. With a single-click inside the canvas it also possible to move the box to the mouse pointer's current position. Panning is also possible with Alt + LMB.

RealFlow provides two basic methods for combining nodes: groups and MultiBodies. Groups can contain an arbitrary number of objects of any type: emitters, objects, cameras, daemons etc. It is also possible to create nested groups. In the editor, groups are displayed as single nodes, but they can be expanded to see what is inside (see “Groups” chapter for more information).

To zoom and pan the viewport or set the focus on particular nodes, the editor offers a wide variety of possibilities:


ZoomMMW or Alt + RMB + mouse drag
PanningAlt + LMB or MMB + mouse drag
Area panningMove light-grey rectangle in the navigator
Activate navigatorZoom in until the navigator appears
Deactivate navigatorZoom out until the navigator disappears
Centre on positionRMB/LMB + double click

 

The “Relationship Editor” does not support drag-and-drop actions between the viewport, the “Nodes” panel and the canvas. The reason is that all windows are equitable: when you remove a node from the viewport it will also be deleted from the “Nodes” panel and the “Relationship Editor”. When you add a new object inside the “Nodes” panel it will simultaneously appear in the editor and the viewport. It is not possible to selectively add or remove a node to/from one of the windows.

In order to connect two nodes you simply have to draw a line between them. From the moment you start to establish such a connection, the editor only shows nodes that accept connections. Other, not supported icons, are greyed out and dimmed.

The “Tab” Menu

A key feature of all node-based editors (incl. “Batch Graphs” and “Simulation Graphs”) is the “Tab” menu. When you press the Tab key, you will see a menu containing all available RealFlow nodes. This menu is simply a copy of the “Edit” menu's “Add” entry. All nodes you create inside the “Relationship Editor” will automatically be added to the “Nodes” panel and the viewport(s) as well.

The input field on top of the menu also provides a very convenient method for fast access to all nodes which fulfil the entered search criteria.

 

 

Node Group

The submenus contain list with all available RealFlow scene elements. To add a new element, choose the desired group and select the appropriate item.

Add to Default Hub

When this option is active, new nodes will always be attached to the "Hub" node that has been created with the first node of your scene.

Set Local Axis by Default

By default, a local coordinate system is applied to new nodes.

Add new Hub

You can create new “Hub” nodes conveniently with this entry.

Add New Note

Notes are editable elements where it is possible to write comments. They do not contribute to a scene and cannot be connected with other nodes.

Nodes

A node is actually nothing more than an element of your scene and it can be seen as a generic term. Daemons, objects, domains or emitters – they are all nodes. When a node is added in RealFlow, it appears in the viewport, the “Nodes” window, and the “Relationship Editor”. No matter which layout element you look at, a node is always represented in a certain way: in the viewport, nodes are displayed as icons, as an object, a box or plane, a circle or a camera. It is possible to select these nodes and apply transformations, e.g. a rotation. In the “Nodes” panel they are elements of an alphabetic list with a small symbol and a name. There, the nodes can be grouped or renamed.

In the “Relationship Editor”, nodes are graphic symbols – a coloured circle with a name tag. The symbols can be moved freely on the canvas and even overlap. With the sophisticated tools from the “Auto Layout” menu it is also possible to arrange them automatically. But: all these position changes are only performed in 2D space and they have no influence on the position in viewport. A change in the node's order, on the other hand, does not affect the order in the “Nodes” panel.

Although these layout elements seem to be separated, they have something in common: it makes no difference where a new node is created – it will always appear in all three areas. The same applies to removing nodes. And when a node is renamed, the new name will appear everywhere as well.

 

 

Related content:
Error formatting macro: contentbylabel: com.atlassian.confluence.api.service.exceptions.BadRequestException: Could not parse cql : null