GUI - Shortcut Editor

Shortcuts are a very convenient method of accelerating your workflow – not only with RealFlow. But, most probably you have your own preferences for which shortcut should trigger a particular function or feature. With RealFlow 2014 you will be able to customize shortcuts easily and manage them in a common editor. To open it, please go to

Tools > Shortcut Editor...

Alternatively, the editor can be called from RealFlow's “Shelves Manager” which is also located under “Tools”. When you open it a new window appears. This window is non-modal and you can access RealFlow's parameters and nodes without closing the editor. Let's take a look at the editor's user interface. The layout is similar to other editor's and managers in RealFlow and subdivided into several areas:

 

 

The "Class ID" Column

Every RealFlow command has its own Id to make it identifiable and unique. Internally, RealFlow uses the Id to access a certain command, and if there is a conflict then it is not clear which command should be executed. Therefore, custom commands require a unique Id – just like their built-in counterparts.

When you add a new command in the manager you will see a predefined Id. There is also a “Generate” button to create a fresh Id. Alternatively, it is also possible to get Ids from “Generate Class ID...” in the “Tools” menu. When you create a new Id you will see that the leading number is always the same for a specific command type:

  • 1 stands for built-in commands
  • 2 is reserved for C++ plugins
  • 4 is the code for Python scripts
  • 6 indicates a graph

You do not have to use the Id suggested by RealFlow and you can also enter any random number, but please make sure that this number is unique. It might be assigned to other commands. In this case you will get a warning message.

The “Command/Shortcut” Columns

This is not only the place where you see all available commands and functions and the assigned shortcut, but also the space to create new shortcuts. The table's left part contains the commands with the icons; the right column shows the shortcut. Under “Command/Shortcut” you will not only find RealFlow's built-in nodes and tools, but also (external) scripts, C++ plugins, and graphs. Everything is sorted alphabetically and clearly arranged. Double-assigned shortcuts are marked with a warning symbol. This also applies to system shortcuts, for example Ctrl/Cmd + S for saving, or Ctrl/Cmd + C for copying the clipboard's content.

To apply or edit a shortcut, just follow these steps:

  • Double-click on the appropriate field under “Command/Shortcut”

  • In the new window, click on the “+” button to create a new shortcut field

  • Press the keys you want to use as a shortcut, e.g. Ctrl + Alt + 2

  • When you release the keys the character sequence is shown in the window.

  • Finish this action with “OK” or click outside the shortcut's field.

 

 

  • If you want to change an existing shortcut double-click on the command first and then on the shortcut in the appearing window

  • Follow the steps above to create the new shortcut

 

RealFlow will detect immediately if the new shortcut is already allocated, and in this case, the previously mentioned warning symbol appears. To correct this and assign a new combination just press the desired keys again and the existing sequence will be overwritten.

You can also create more than one shortcut for a command by clicking on the “+” button again. If you want to remove a sequence you have to click on the appropriate field, and click on the “-” button. Finally, confirm your settings with “OK” or abort with “Cancel”.

It also possible to mark commands to perform various actions on this selection, for example to reset these commands or export the shortcuts (see “The 'Button' Bar” below). Commands can be selected by

  • clicking on a single entry

  • holding the mouse key pressed and dragging over the “Commands/Shortcut” list

  • shift-clicking on the commands

  • Ctrl-/Cmd-clicking on the commands to select arbitrary entries

 

Finally, there is the “Class ID” column showing the ID for each of RealFlow's built-in or external resources. Ids must be unique and they are used internally to track changes, When you add a new script, graph , or plugin, an Id is assigned automatically, but there is also a way to change it in the Commands Manager”. Ids of built-in functions cannot be changed by the users.

The “Filter” Area

Here you can search quickly through RealFlow's commands and see the associated shortcuts. Simply type in a few characters in the empty field and RealFlow will display the results in realtime in the “Commands” table. Alternatively, it is also possible to filter against predefined groups with the “Filters” button. When you click on it you can choose from several options in a separate window. To enable your filters, click on “OK”.

 

 

Display commands of type

Choose, which category you want to display by checking/unchecking the entries.

Show all

This is the default option and shows the entire range of commands and shortcuts.

Show only shortcuts with conflicts

A conflict exists when a shortcut is defined several times or when a system shortcut has been used.

Show only modified shortcuts

If you have changed several shortcuts during a session then it is often a good idea to keep track of these modifications. To do this, activate this option.

The “Buttons” Bar

Imagine you are a freelancer working in a studio with RealFlow 2014. One of the first things you normally do is to adjust the layout and the shortcuts to your own requirements. With regards the layout it is easy: you just copy the appropriate LAY file and paste it to RealFlow application folder under “layout”. Then you restart the program, and define your layout file as the default layout under “Preferences”. That's it! Recreating all shortcuts, on the other hand, is a very tedious and time-consuming task. Not so with the “Export” and “Import” buttons of the “Shortcut Editor”.


"Export" Button

All shortcut definitions are exported to a XML file which can be edited with any text processing program. The good thing is that you can export the entire set of command-shortcut pairs or just a selection. When you click on “Export” a new window opens where you can make your settings:

 

 

Export location

This is the folder/location where the XML will be written to. If the file, specified in the input field, already exists you will see a yellow warning sign.

“…” Button

With a click on this button you can define a new location and name for the XML file.

Export all

By default, all commands and shortcuts are written to an XML file.

Export modified

When you have changed and edited RealFlow's shortcuts you can keep track of these modifications with this option: only the shortcuts you have changed during a RealFlow session will be written to file.

Export selection

If you have made a commands/shortcut selection then you have the option of only saving these strings to the XML.

Export modified and selected

As the name suggests, here only selected and modified sequences will be written to file.

Export commands of type [ type selection ]

Of course, it is also possible to restrict the export to certain command types or groups. Available options are “All”, “Built-in”, “C++ plugins”, “Python”, and “Graphs”. These types can be combined freely.

 

"Import" Button

The XML files you have written with the “Export” function can be (re)loaded into RealFlow with this button. Simply spot the desired file and open it. RealFlow analyses the file and informs you about conflicts and the number of changed shortcuts. XML files from graphs or with scene nodes can not be used with this import function.


"Reset Selected" Button

Sometimes it is necessary to reset only specific shortcuts to their default, and this is exactly what you can do with this button. Create a selection, and press this button to restore the initial key combinations. If a command did not have a shortcut defined by default then the current one will be deleted and lost. To avoid accidental loss of data we recommend storing a copy of your shortcut list with the “Export” button.


"Restore Default" Button

The mode of operation is exactly the same as with “Reset Selected”, but here all commands and shortcuts are affected/reset. Please store a copy of the current set of shortcuts with “Export” before you press this button. For security reasons, RealFlow asks for confirmation before the shortcuts will be reset.


"Close" Button

Once you have finished your changes, close the editor with this button.

Right-Click Menu Filter

Here you will find a menu for simple copy/paste and undo/redo actions – it contains common functions and does not require further explanation:



 

Related content: