Endless Oceans

With RealFlow's internal implementation of Maxwell Render you are able to create realistic, physically correct images from simulations directly inside our simulation tool. With RealWave surfaces you also have the possibility of extending an ocean segment according to your requirements. Please bear in mind that this method only works with the “Ocean Statistical Spectrum” modifier. Other modifiers are not tileable. This also applies for combinations of the “Ocean Statistical Spectrum” with other modifiers, for example “Fractal” or “Gerstner".


An endless ocean rendered with RealFlow'' implementation of Maxwell Render.


Here is the nodes list:

  • 1 “RealWave” object
  • 1 “Plane” node (optional)

 

All scene elements can be added from RealFlow's “Edit” menu:

  • Add > RealWave | Objects
  • RealFlow nodes can be moved, scaled, and rotated with the WR, and E keys.
  • Imported objects from SD files have to be unlocked before they can be transformed with Selected object > Node Params > Node > SD ↔ Curve
  • Viewport perspective is changed with the 123, and 4 keys.
  • Shading modes are toggled with the 789, and 0 keys.

The Setup

  • Add a RealWave surface (there cannot be more than one RealWave node in a scene).

  • Rescale the surface to your needs with the R key or the parameters under Node Params > Scale. The surface should be a squared mesh.

  • Right-click on the “RealWave01” node and choose Add Wave > Ocean Statistical Spectrum

Adjusting the Surface

The creation of an extended ocean in RealFlow is based on a tiling approach. Therefore it is important that the surface is as big as possible to avoid repeating patterns. When you have a small surface, e.g. 5 m x 5 m and the camera is far away then you will see repetitions and regular patterns. To avoid this, the surface's dimensions have to match the current point of view. A good start is a size of at least 25 m x 25 m, better 50 m x 50 m:

  • RealWave01 > Node Params > Node > Scale > horizontal axis > 50.0

  • Under Node Params > RealWave > Polygon size you can adjust the mesh's resolution. Decrease this value to get more details.

 

With a dimension of 50 m x 50 m you will hardly see any waves and the surface is most probably totally flat. To change this, select the “OceanStatisticalSpectrum01” modifier and enter

  • Node Params > Ocean Statistical Spectrum > Vertical Scale > 0.025

  • Sharp crests can be achieved with Choppiness > 1.0 or higher

  • Changes are only visible after a “Reset”

 

The First Render

A rendered preview can be triggered with a single click: simply click on the “FIRE” button to open the “Maxwell Interactive” window. After a few seconds you will see a rendered representation of the viewport. This view can be changed in realtime by panning, orbiting, and zooming the viewport:

  • Rotate the viewport with Alt + LMB

  • Pan the viewport with Alt + MMB

  • Zoom the viewport with Alt + RMB or scrolling the mouse's middle wheel

The scene's lighting setup can also be changed, for example the global light intensity or the current time of the day. Click on the “Maxwell Scene Preferences” and make your settings. With “Apply” the changes are shown in realtime. Once you are happy with the adjustments, confirm with “OK”.

 

RealWave's “Maxwell Render” Tab

To access the RealWave surface's Maxwell Render parameters, select the “RealWave01” node and open

  • Node Params > Maxwell Render


With “Tile 1” and “Tile 2” you are able to define the number of repetitions. When you change these values, RealFlow will update the “Maxwell Interactive” window automatically and you will not have to trigger the voxelization/render process manually. There is another important thing with “Tile 1” and “Tile 2” you have to know:

Even-numbered values (2, 4, 6, etc.) do not have any effect on the render and you won't see any changes. The reason is linked to how RealFlow attaches the tiles to the already existing surface. New tiles are created around the RealWave surface and this means that the smallest number of tiles is 3 x 3. If you want to add another “layer”, the next valid number is 5 x 5, then 7 x 7, and so on.

At the moment, the surface is opaque and has the same colour as specified under the “RealWave01” node's Node Params > Node > Color field. To change this, you can either change the colour itself or choose from the “Maxwell Render” tab's material database:

  • Node Params > Maxwell Render > Material > water_ocean

 

 

Again, the new preview is triggered automatically. To enhance contrast and get a more ocean-like impression, follow these steps:

  • Click on “FIRE” to stop the render process

  • Edit > Add > Objects > Plane

  • Plane01 > Node Params > Node > Scale > vertical axis > 20.0 (or higher – this depends on the size of the RealWave surface and the number of tiles)

  • Shift the plane node beneath the RealWave surface with the W key

  • Restart the render with a click on the “FIRE” button

 

Related content:
Showing first 15 of 49 results